Desktop and mobile users have distinct task requirements
Incident Report for HUMAN Protocol
Postmortem

Identified some users were not paid because of higher security scores, rest all users have been getting paid on desktop with a higher payout delay.

Posted Sep 21, 2023 - 10:55 UTC

Resolved
This incident has been resolved.
Posted Sep 20, 2023 - 05:20 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 05, 2023 - 06:31 UTC