Payouts are delayed
Incident Report for HUMAN Protocol
Resolved
This incident has been resolved.
Posted Dec 20, 2023 - 04:31 UTC
Identified
PolygonScan is going under maintenance.
Posted Dec 19, 2023 - 08:10 UTC