Payouts are delayed
Incident Report for HUMAN Protocol
Resolved
This incident has been resolved.
Posted Sep 05, 2023 - 06:28 UTC
Investigating
Polygonscan is under maintenance.
Posted Aug 08, 2023 - 09:09 UTC