Payouts are delayed
Incident Report for HUMAN Protocol
Resolved
This incident has been resolved.
Posted Oct 24, 2023 - 10:20 UTC
Identified
PolygonScan is under maintenance.
Posted Oct 24, 2023 - 07:43 UTC