Payouts are delayed
Incident Report for HUMAN Protocol
Resolved
This incident has been resolved.
Posted Jul 04, 2023 - 09:22 UTC
Investigating
Polygonscan is under maintenance.
Posted Jul 04, 2023 - 07:37 UTC