Payouts are delayed
Incident Report for HUMAN Protocol
Resolved
This incident has been resolved.
Posted Jan 04, 2024 - 05:07 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jan 03, 2024 - 08:10 UTC
Identified
Polygonscan is under maintenance.
Posted Jan 03, 2024 - 07:27 UTC