An unexpected error (503 error)
Incident Report for HUMAN Protocol
Postmortem

IM confirmed that they were experiencing problems with their services.

Posted Oct 24, 2023 - 09:05 UTC

Resolved
Issue is now resolved.
Posted Oct 24, 2023 - 09:04 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 24, 2023 - 08:58 UTC