Payouts may be delayed.
Incident Report for HUMAN Protocol
Resolved
This incident has been resolved.
Posted Dec 06, 2023 - 07:59 UTC
Identified
Polygonscan maintenance issue.
Posted Dec 05, 2023 - 07:54 UTC