An unexpected error (503 error) : "Something went wrong. Please, try again later"
Incident Report for HUMAN Protocol
Postmortem

IM confirmed that there is a problem with a server with stats.

Posted Oct 27, 2023 - 09:07 UTC

Resolved
This incident has been resolved.
Posted Oct 27, 2023 - 09:06 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 26, 2023 - 08:07 UTC