Job Launcher is down
Incident Report for HUMAN Protocol
Postmortem

There was an issue with Vercel about payments and it was resolved with them.

Posted Dec 07, 2023 - 06:54 UTC

Resolved
This incident has been resolved.
Posted Nov 22, 2023 - 10:16 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 16, 2023 - 11:47 UTC