Payouts are delayed
Incident Report for HUMAN Protocol
Resolved
This incident has been resolved.
Posted Sep 20, 2023 - 05:19 UTC
Identified
PolygonScan is under maintenance
Posted Sep 19, 2023 - 09:10 UTC